【Laravel】LaravelでBootstarap4を導入する方法

Facebook にシェア
Pocket
LINEで送る
このエントリーを Google ブックマーク に追加

cd Laravelのプロジェクト
vi resources/assets/sass/_bootstrap.scss

以下を記述。

// Fonts
@import url("https://fonts.googleapis.com/css?family=Raleway:300,400,600");

// Variables
@import "variables";

// Bootstrap
@import "~bootstrap/scss/bootstrap";

記述後、以下コマンドを実行。

composer require laravelnews/laravel-twbs4
php artisan preset bootstrap4-auth
yarn && yarn dev

Bootstrap4がインストールされたかどうかを素人的に確認する。

$ cat public/js/app.js |grep v4.0.0
  
 * Bootstrap v4.0.0-beta.3 (https://getbootstrap.com)
 * Bootstrap (v4.0.0-beta.3): util.js
 * Bootstrap (v4.0.0-beta.3): alert.js
 * Bootstrap (v4.0.0-beta.3): button.js
 * Bootstrap (v4.0.0-beta.3): carousel.js
 * Bootstrap (v4.0.0-beta.3): collapse.js
 * Bootstrap (v4.0.0-beta.3): dropdown.js
 * Bootstrap (v4.0.0-beta.3): modal.js
 * Bootstrap (v4.0.0-beta.3): tooltip.js
 * Bootstrap (v4.0.0-beta.3): popover.js
 * Bootstrap (v4.0.0-beta.3): scrollspy.js
 * Bootstrap (v4.0.0-beta.3): tab.js
 * Bootstrap (v4.0.0-alpha.6): index.js
    throw new Error('Bootstrap\'s JavaScript requires at least jQuery v1.9.1 but less than v4.0.0');

うん、なんとか入っていそう。

Related posts

コメントを残す