CentOS7+ Python3.5+pip でpillowをインストールした際に”ValueError: jpeg is required unless explicitly disabled using –disable-jpeg, aborting”

Facebook にシェア
Pocket
LINEで送る
このエントリーを Google ブックマーク に追加

$pip install pillow 

・・・・・・・・・・・・・・・

    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-build-cdjv5gwj/pillow/setup.py", line 767, in <module>
        zip_safe=not debug_build(),
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/core.py", line 148, in setup
        dist.run_commands()
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/dist.py", line 955, in run_commands
        self.run_command(cmd)
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/dist.py", line 974, in run_command
        cmd_obj.run()
      File "/home/psychopass/psycho_python/lib/python3.5/site-packages/setuptools/command/install.py", line 61, in run
        return orig.install.run(self)
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/command/install.py", line 539, in run
        self.run_command('build')
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/dist.py", line 974, in run_command
        cmd_obj.run()
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/command/build.py", line 135, in run
        self.run_command(cmd_name)
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/dist.py", line 974, in run_command
        cmd_obj.run()
      File "/home/psychopass/.pyenv/versions/3.5.1/lib/python3.5/distutils/command/build_ext.py", line 338, in run
        self.build_extensions()
      File "/tmp/pip-build-cdjv5gwj/pillow/setup.py", line 516, in build_extensions
        (f, f))
    ValueError: jpeg is required unless explicitly disabled using --disable-jpeg, aborting

    ----------------------------------------
Command "/home/psychopass/psycho_python/bin/python3.5 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-cdjv5gwj/pillow/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('
', '
'), __file__, 'exec'))" install --record /tmp/pip-hrmkty4s-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/psychopass/psycho_python/include/site/python3.5/pillow" failed with error code 1 in /tmp/pip-build-cdjv5gwj/pillow

 

解決方法

libjpeg-develをインストール

$ sudo yum install libjpeg-devel

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です