TweepyのTwitter StreamingがPython3.7.0で使えない模様

Facebook にシェア
Pocket
LINEで送る
このエントリーを Google ブックマーク に追加

Python3.7.0でtweepyを使おうとしたところ

Twitter Streaming APIをPython3.7.0環境のTweepy使おうとしたところ、次のようなエラーが出た。

何かなーと思ったら、asyncが3.7.0から予約語に入っていた。

What’s New In Python 3.7

対処方法としては、site-packages/tweepy/streaming.pyの async を sync などの変数名に置換してしまうことだけど、
pull request出したほうが良さそうね。

TweepyのTwitter StreamingがPython3.7.0で使えない模様” に対して1件のコメントがあります。

  1. It’s great that you are getting thoughts from this post as well as from our argument made at
    this time.

    1. umentu_blog より:

      Thx!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です